Cloud Functions Invocation Performance is Degraded for Some Customers

Incident Report for NGC

Resolved

This incident has been resolved.
Posted Oct 18, 2025 - 22:33 PDT

Investigating

Cloud Functions invocation performance is degraded for some customers. Please bear with us as we address this issue. Thank you.
Posted Oct 18, 2025 - 20:47 PDT
This incident affected: Cloud Functions.