Issues with NGC Core Services
Incident Report for NGC
Resolved
The incident NGC Core Services issues has been resolved
Posted Mar 07, 2023 - 11:36 PST
Monitoring
A fix for the NGC Core Services issues has been applied and we are monitoring the service for stability.
Posted Mar 07, 2023 - 11:13 PST
Investigating
The NGC Core Services are currently experiencing issues that are affecting admins ability to add new users to an NGC org.

The issues are being actively investigated and updates will be posted on this status page.
Posted Mar 07, 2023 - 10:41 PST
This incident affected: NGC Core Services.