Issues with NGC service
Incident Report for NGC
Resolved
Issues affecting the NGC service have been resolved and the service is operating normally.
Posted Oct 26, 2023 - 10:14 PDT
Monitoring
A fix for the NGC service issues has been applied and we are monitoring the service for stability.
Posted Oct 26, 2023 - 09:24 PDT
Identified
The cause of issues with NGC service has been identified and a fix is being applied.
Posted Oct 26, 2023 - 09:17 PDT
Investigating
The NGC service is currently experiencing issues which are affecting users ability to use NGC.

The issues are being actively investigated and updates will be posted on this status page.
Posted Oct 26, 2023 - 08:57 PDT
This incident affected: NGC Core Services, NGC Catalog, Private Registry, Base Command, and Fleet Command.