Cloud Functions Elevated latencies and Error rate for gRPC connections

Incident Report for NGC

Resolved

This incident has been resolved.
Posted Jan 21, 2026 - 16:51 PST

Update

We are continuing to investigate this issue.
Posted Jan 21, 2026 - 16:47 PST

Update

We are continuing to investigate this issue.
Posted Jan 21, 2026 - 15:06 PST

Investigating

Cloud Functions is experiencing elevated invocation errors and increased latency for some customers in US-west2, primarily due to gRPC connection timeouts. We’re actively mitigating and will provide updates as we restore full stability. Thank you for your patience.
Posted Jan 21, 2026 - 14:44 PST
This incident affected: Cloud Functions.