Issues with NGC Catalog service

Incident Report for NGC

Resolved

Issues affecting the NGC Catalog service have been resolved and the service is operating normally.
Posted Mar 10, 2026 - 19:19 PDT

Investigating

Issues with NGC Catalog service are still being investigated. Further updates will be posted on this status page.
Posted Mar 10, 2026 - 19:06 PDT
This incident affected: NGC Catalog.