Issues with NGC services

Incident Report for NGC

Resolved

Issues affecting the NGC services have been resolved and the service is operating normally.
Posted Jun 10, 2025 - 11:20 PDT

Update

We are continuing to monitor for any further issues.
Posted Jun 10, 2025 - 10:26 PDT

Monitoring

A fix for the NGC services issues has been applied and we are monitoring the service for stability.
Posted Jun 10, 2025 - 10:22 PDT

Identified

The cause of issues with NGC services have been identified and a fix is being applied.
Posted Jun 10, 2025 - 09:44 PDT

Investigating

NGC services are currently experiencing issues which are affecting users.

The issues are being actively investigated and updates will be posted on this status page.
Posted Jun 10, 2025 - 08:40 PDT
This incident affected: Cloud Functions.