Issues with NGC Catalog service
Incident Report for NGC
Resolved
Issues affecting the NGC Catalog service have been resolved and the service is operating normally.
Posted Nov 01, 2023 - 17:44 PDT
Update
We are continuing to monitor for any further issues.
Posted Nov 01, 2023 - 17:01 PDT
Monitoring
A fix for the NGC Catalog service issues has been applied and we are monitoring the service for stability.
Posted Nov 01, 2023 - 16:57 PDT
Identified
The cause of issues with NGC Catalog service has been identified and a fix is being applied.
Posted Nov 01, 2023 - 12:36 PDT
Investigating
The NGC Catalog service is currently experiencing issues which are affecting users.

The issues are being actively investigated and updates will be posted on this status page.
Posted Nov 01, 2023 - 12:36 PDT
This incident affected: NGC Catalog and Fleet Command.